
ARIS EDIT Lite

for Microsoft Windows™

Version 1.4

ARIS Informations-Systeme
Parkstr. 2
D-85646 Anzing
Germany
Phone: +49 8121-4562-4
Fax: +49 8121-4562-5



Document release date: February 25, 1994
Printed in Germany
Document AELITE.DOC

Information in this document is subject to change without notice and does not represent a commitment on the part of ARIS. The software
described in this document is furnished under a licence agreement or nondisclosure agreement. The software may be used or copied only in
accordance with the terms of the agreement. It is against the law to copy the software on any medium except as specifically allowed in the
license or nondisclosure agreement. No part of this manual may be reproduced or transmitted in any form or by any means, electronic or
mechanical, including photocopying and recording, for any purpose without the express written permission of ARIS.

(c) 1994 Alexander Riedel Informations-Systeme
All rights reserved

Microsoft Windows is a trademark of Microsoft Corp.

-2-



ARIS LICENSE AGREEMENT
This is an agreement between you, the end user, and us, Alexander Riedel Informations Systeme. By opening the sealed package, you are 
agreeing to be bound by the terms of this agreement. If you do not agree to these terms, promptly return the unopened disk package and all 
accompanying materials to your dealer or to us for a refund.

1. License
We grant you the right to use the enclosed software program (the Software) on a single terminal connected to a single computer. You may not
use this software in a network or otherwise use it on more than one computer or terminal at a time.

2. Copyright
The Software is owned by us and is protected by the German copyright laws and international treaty provisions. You must treat the Software 
like any other copyrighted material, such as book or musical recording. You may, however, either (a) make one copy of the software for 
backup or archival purposes, or (b) transfer the software to a single harddisk, provided you keep the original solely for backup or archival 
purposes. You may not copy any written material s accompanying the Software.

3. Other restrictions
You may not rent or lease the Software, but you may transfer it and the accompanying written materials on a permanent basis provided you 
retain no copies and the recipient agrees to the terms of this agreement. You may not reverse engineer, decompile, or disassemble the 
software.

4. Dual media software
If this package contains both 3 1/2 inch and 5 1/4 inch disks, then you may use only the disks appropriate for your single-user computer. You 
may not use the other disks on another computer or transfer them to another user except as part of a permanent transfer of all Software and 
written materials.

5. Limited warranty
We warrant that the Software will perform substantially in accordance with the accompanying written materials for a period of 90 days from 
the date of receipt. Any implied warranties on the Software are limited to 90 days.

6. Remedies
Our entire liability and your exclusive remedy shall be, at our option, either (a) return of the price paid or (b) repair or replacement of the 
Software that does not meet our limited warranty and that is returned to us with a copy of your receipt. Our limited warranty is void if failure 
of the Software has resulted from abuse or misapplication. We warrant the replacement Software under this limited warranty for the 
remainder of the original warranty period or 30 days, whichever is longer.

7. No other warranties
We disclaim all other express or implied warranties, including the implied warranties of merchant ability and fitness for particular purpose. 
Our limited warranty gives you specific legal rights. You may have other rights, which vary from state to state.

8. No liability for consequential damages
In no event shall we be liable for any damages whatever, including loss of profits, arising out of the use or inability to use this software, even 
if we have been advised in advance of the possibility of such damages.
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1. Introduction

ARIS EDIT Lite is a powerful text editor for Microsoft Windows. You can use ARIS EDIT Lite as a perfect
replacement for the standard text editor of Windows, NOTEPAD.
While NOTEPAD is only able of editing one file at a time and can only load files of approximately. 32KBytes in
size, ARIS EDIT Lite allows you to edit a maximum of 32 files at once, where each file is not limited in its size.
Well, two limitations it has: The size of all loaded files may not exceed the amount of available virtual memory
and the maximum line length is limited to 32536 characters.
Please consult your Windows manual for more information about virtual memory and how to increase its size if
you encounter a situation where ARIS EDIT Lite is not able to load a file.
Aside  from overcoming the  limitations of  NOTEPAD,  ARIS EDIT Lite  offers  a  wide  variety  of  advanced
features such as:

- Advanced printing with line numbers and page headers
- Brace matching
- Built in GREP for scanning files on the hard disk
- Change the working directory on the fly
- Direct jump to lines
- Drag and drop support
- Easy font selection for every window
- File size only limited by available virtual memory
- Lines may be up to 32K characters wide
- Loads multiple files at once
- MRU (Most recently used) list of accessed files
- Multi level undo and redo
- Regular expression search
- Smart icons for the most common functions
- Smart insert with the mouse

2. Installation

Installing ARIS EDIT Lite to your hard disk is an easy process. Simply insert the disk into a floppy drive and run
the setup program. To do this, select “Run” from the “File” menu of the Windows Program Manager and enter
“A:SETUP”. If you have placed the installation disk into another drive than A: you have to subsitute the A with
the letter of the drive you are using.

Now an automated installation procedure prompts you for a directory. If the default installation directory (C:\
AELITE) does not suit you, simply type in another drive and/or directory. If the directory you are specifying
does not yet exist it will be created by SETUP.

Now SETUP will  copy  all  necessary  file  to  your  hard  disk.  Please  note  that  some  DLLs  (Dynamic  Link
Libraries) will be copied to the system directory of your Windows installation if they do not already exist or if
older versions of this DLLs are detected. These DLLs are placed in this Windows subdirectory rather than in the
installation directory as some other programs use this DLLs too and in order to ensure that you have not multiple
copies of the same DLL on your hard disk, they are installed to that directory.

SETUP will also copy an AELITE.INI file to your Windows subdirectory. This file is used by ARIS EDIT Lite to
store its configuration. Again this file is not installed to the installation directory you specified. This is done
because the Windows directory is the common place for initalisation files to reside.

3. The menus of ARIS EDIT Lite

The menus of ARIS EDIT Lite behave just like that of any other Windows program. If you are not yet familiar
with the usage of the pull down menus of Windows applications, please consult your Windows manual for a
description.
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Several topics in the menus have so-called accelerator keys assigned to them. These keys are displayed to the
right of a topic if the menu is open. While editing in a file you may use these accelerator keys to access menu
functions without opening the corresponding menu.
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3.1 The File menu

The File menu contains all topics that are associated with the handling of files, such as loading and saving.

- Open... This topic opens a dialog box where you may select  one or more files for opening.
After  pressing the OK button,  each file  will  be read into memory,  a  new window will  be
created for every file and the first page of the file will be displayed. For a deeper discussion of
file opening please refer to chapter 4.

- New This topic opens an empty window for a new file. The name ARIS EDIT Lite initially
assigns to this file is "Untitled".
If you attempt to save this file ARIS EDIT Lite will prompt you for a name for this new file. 

- Read... This menu topic allows you to select an existing file for inserting it  at the current
cursor position.

- Directory... This menu topic allows you to change the current working directory. The dialog behind this
topic also allows you to access a history of working directories for easy switching between
different directories.

- Close This  function  closes  the  currently  active  window.  The contents  of  the  window is
discarded. If the file in that window has been changed after it  was last saved, you will be
prompted if you want to save it now. If you decide not to save your changes here, all changes
will be lost.

- Close all Selecting this topic closes all editing windows at once. If any of the files in these windows
have been changed after last saved, you will be prompted if you want to save that file now.

- Save This topic saves the file in the current window under its original name. You will not
be prompted for overwriting if this file already exists, since ARIS EDIT Lite assumes that you
have loaded the file under this name.

- Save as... This menu item allows you save a file under a different name. If you specify a name of a file
that already exists, you will be prompted for overwrite permission.

- Save all This  topic  walks  through  all  opened  editor  windows  and,  if  necessary,  saves  the  file
accordingly. Files that have not been changed after loaded or saved last remain untouched.

- Grep... This function allows you to scan files on your disk for regular expressions. Several
options allow you to exactly specify which files should be scanned.

- Print... This  menu  item prints  the  file  in  the  currently  active  window.  Before  the  actual
printing takes place you are able to change the printer and/or its setup. The current adjustments
from the Print Layout dialog will be used.

- Print layout... With this topic you are able to configure the layout of the printing output of ARIS EDIT Lite.
You can select the border size, include or exclude line numbers or define page headers.

- Exit By selecting this menu topic you end your current session with ARIS EDIT Lite. All
currently open windows will be closed at once. If any file in an open window has been changed
you will be prompted for saving it.
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3.2 The Edit menu

The edit menu contains several topics for clipboard handling. It also enables you to reverse editing operations or
to repeat reversed operations.

- Undo This function reverses the last editing operation. The amount of operations that can be
reversed is limited by a buffer of 4096 bytes. If you find this to small from your experience,
please contact our technical support.

- Redo This item reverses the last undo operation. Whenever you have used Undo to much
you can easily recover your work.

- Copy By using this topic the highlighted text from the currently active window is copied to
the Windows clipboard. You can use the Paste function to insert this text in another file or in
another location in the same file. As the text copied to the clipboard is placed there as ASCII
text, this text is available to other applications too.

- Cut This function too copies the marked text  from the currently active window to the
clipboard. Additionally the marked region is deleted from the text. You may use this topic in
combination with the Paste topic to move text from one location to another.

- Paste This topic inserts the contents of the Windows clipboard at the current cursor position
in the active window.

- Clipboard This menu item start the Windows clipboard in order to show you its contents.

3.3 The Goto menu

The goto menu contains all items that allow you to jump to certain locations in the active window. You can
search for a string, replace occurances of strings by other strings or jump to a specific line number.

- Search... This topic causes the Search dialog to pop up. Into this dialog you can either enter a simple 
string or a regular expression you want to search for.

- Replace... By selecting this topic ARIS EDIT Lite pops up the "Search and Replace" dialog. You can
search for a specific string and, when found, decide for each occurance of this string whether to
replace it by another string or not.

- Line number... This function allows you to directly jump to a specific line number. If you enter a number
which is higher than the actual number of lines in that file the cursor will be placed at the
beginning of the last line in the file.

3.4 The Options menu

This menu enables you to adjust the behavior of ARIS EDIT Lite to your preferences.

- Preferences... After selecting this topic a dialog enables you to adjust the length of a tab stop (default: 8) and 
to specify whether ARIS EDIT Lite should perform automatic indenting. That is, when you 
insert a new line, if ARIS EDIT Lite should copy the level of indention from the line above. 
This feature is switched on per default.

- Font... This item lets you select the font for the current window. Please note that you can
select an individual font for each single window. However, any newly created window (by
opening another file) will have the font you selected last. The fonts you are able to choose from
are only the fixed pitch fonts installed in your system. As ARIS EDIT Lite is intended as an
ASCII file editor and not as a word processor the overhead of dealing with variable pitch fonts
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cannot be justified.
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3.5 The Run menu

This menu allows you to start other programs from any ARIS EDIT Lite session without switching back to the
Program Manager or the Windows File Manager.

- Programm... This topic provides a point and shoot dialog, where you can easily select the program file
(COM, EXE, BAT) you want to execute. There is no difference whether you select a DOS or a
Windows program file. Each will be executed at once.

- DOS This item starts a DOS box.

3.6 The Window menu

- Tile The Tile  command redisplays windows on your desktop in  such a  way that  each
window becomes the same size.

- Cascade The Cascade command arranges the windows on your desktop in a tiered or cascading fashion.

- Arrange icons The Arrange icons command rearranges the icons on your desktop into neat rows and columns.

3.7 The Help menu

- Keyboard layout... This shows you a table which describes the shortcut keys of ARIS
EDIT Lite and their functions.

- Using the mouse... You will get information how you can use the mouse in ARIS EDIT
to copy, delete and paste text.

- About ARIS EDIT Lite... This  topic  displays  version  information  about  ARIS  EDIT  Lite.  When
requesting support the version and the build date must be supplied.

4. Loading files into ARIS EDIT Lite

There are four ways in which you can instruct ARIS EDIT Lite to open an existing file. Each of these four 
methods are described in the following chapters.

4.1 Using the "File open" dialog

You can use the "File open" dialog to open one or more files. This dialog appears whenever you select the topic
"Open..." from the File menu or when you click to the open symbol in the smart icon bar.
The picture below shows the smart icon bar of ARIS EDIT Lite.
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(Picture of File Open dialog)

In the dialog box shown above you can now select one or more files to load. A single file can be loaded by
selecting its name in the file list and pressing the OK button. Double clicking on a file name results also in this
file being loaded.
For selecting more than one file click to each file's name while holding the Ctrl key on your keyboard down. You
will see each file's name becoming highlighted when you click on it. After you have selected all files you want to
load  press the OK button and ARIS EDIT Lite will load all selected files.

4.2 Loading files by command line

You can instruct ARIS EDIT Lite to load file immediately on startup by specifiying their names on the command
line. This is specially useful if you want to have several copies of the ARIS EDIT Lite icon in various groups on
your desktop, where each icon loads different files. You can copy the icon of ARIS EDIT Lite by clicking on one
icon in a group of the Program Manager while holding the Ctrl key down and dragging it to another place. In the
properties of such a copy you can now specify the files to load on the commandline. In the picture below you see
an example how to load the WIN.INI on startup.

Of course you can enter more than one file at this place. If the files you want to load do not exist in the specified
working directory you must supply their full path names (i.e. C:\WINDOWS\WIN.INI).
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4.3 Using drag&drop from the Windows File Manager

If you want to edit one or more files in an already running instance of ARIS EDIT Lite you do not need to go
through the file open dialog several times. While the file open function allows you to select several files at once,
it requires that the files reside in one directory. You can simply grab the files from the Windows File Manager
and drag them to the window (or icon if it runs minimized) or ARIS EDIT Lite while holding the left mouse
button down. Once the cursor is above the window or icon you simply release the left mouse button (drop the
files) and ARIS EDIT Lite will load them.

A good preparation is to include ARIS EDIT Lite in your Autostart group, running it minimized on Windows
startup. Whenever you now encounter a file you want to edit or view while browsing your hard disk or a floppy
with the File Manager you can simply drag this file to the icon of ARIS EDIT Lite in order to load it.

4.4 Using the MRU list

ARIS EDIT Lite maintains a MRU list (Most Recently Used) of up to eight files you edit. Each time you open a
file it  is moved to the top of that list while all other files will be moved one place down with the last file
dropping out of the list if there are already eight files in it.
If you load a file that is already in the list it also will be moved to the top of the list but with no file dropping out.
The list is maintained in the File menu just above the Exit topic. Now if you want to load a file you worked with
recently just open the File menu and select the file's name from the list.

5. Editing files with ARIS EDIT Lite

Editing  with ARIS EDIT Lite  is  just  the  same as  with each  other  editor  or  word  processor.  However,  the
following chapters will give you a brief explanation of the basic editing tasks.

5.1 Moving the cursor

The cursor, also called the caret to mark the difference to the mouse cursor is a full block rather than a vertical
line as in many other programs. This is to enhance its visibility on high resolution systems.
This cursor can be moved around in the text by using the keyboard or the mouse. As for the keyboard the so-
called cursor keys do what you expect them to do:

You can also use the left and right arrow keys to jump from one word to the other if you hold down the Ctrl key
while pressing a cursor key. The caret will jump to the previous or the next word according to the cursor key you
use.
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Holding the Ctrl key while pressing the up and down cursor keys results in jumping to the previous or next blank
line in the text. Note that lines containing only spaces or tabs are not recognized as blank lines.
Some other keys on your keyboard allow you to move in greater jumps through the text. Again these keys do
exactly what you may expect according to their names:

5.2 Inserting and deleting text

Inserting new text into a new or already existing document is just as simple as typing on a typewriter.

Move the cursor to the location where you want to enter new text and start typing. As you do so, you will see the
characters you type appear at the current location of the caret. Any subsequent text of the current line will be
moved to the right.

If you want to enter a new blank line, just place the cursor at the beginning of the line before which you want to
enter a new line and press ENTER. Alternatively you can press the ENTER key at the very end of the line after
which you want to insert a new line. The latter let it work just like a typewriter, type your text and press ENTER
and you can start typing the next line.

Note that a newly inserted line automatically gets the same indention as the line above the new line when you
selected "Autoindent" in the preferences as shown in the following picture.

That way you can keep an indention as long as you wish. As the indention is simply copied from the line above,
it depends on that line whether you have a new line indented with tabs or spaces.

For deleting text you have several choices depending on what you want to delete. To simply delete backwards
perhaps to correct a typo you will use the BACKSPACE key. This key deletes the character right from the
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current caret position and the caret moves one character to the right. Note that a carriage-return (the character
that causes line breaks) is treated as a simple character here. If you press the BACKSPACE key at the beginning
of a line the carriage-return at the end of the line above the current line is deleted and the current line will be
concatenated to the line above.
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Another key for deleting is the DEL key, which simply deletes the character at the current text cursor position,
that is the character right under the caret.

If you want to delete a larger part of the text, such as a whole line or the part of the line from the currennt cursor
position to the end of the line, there are two special key combinations for that.

- Press Y while holding the Ctrl key down to delete the current line and
- press Q in combination with the Ctrl key to delete the rest of the line starting at the current caret position.

For even larger parts you have to select the text you want to delete before pressing the DEL key. For selection
you can either use the mouse (see chapter "Using the mouse") or the cursor keys respectively. To select text with
the  cursor  keys  simply  hold  down the  Shift  key  while  moving  the  text  cursor  as  usual.  You  will  see  the
highlighted area grow or shrink depending on the direction you move the caret.

After  you have selected all  text  you want  to delete you simply press the DEL key in order  to remove the
highlighted part from the text.
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6. Using the Windows Clipboard

Besides supporting the standard technique and accelerators for cutting (or copying) and pasting text, ARIS EDIT
Lite has two shortcut methods:

Using the Right Mouse Button
To cut a block of text from a document and place it on the clipboard:

1. Press the right mouse button.
2. Drag the mouse through the text to be cut.
3. Release the mouse button.

To copy instead of cut, hold the Shift key down when releasing the mouse button.

To paste a block of text from the clipboard into a document:

1.  Move the mouse to the location where the text should be pasted.
2.  Press and release the right mouse button.

Using the Numeric Keypad
ARIS EDIT Lite support cut and paste using the numeric keypad in the fashion of the Brief editor:

To cut the current line, press the Gray Minus key

To copy the current line, press Gray Plus
To paste before the current line, press the Insert key
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7. Matching Parentheses and Braces

Given a parenthesis or a brace, ARIS EDIT Lite can find the matching parenthesis or brace.  To find the match:

1.  Move the mouse to a brace or parenthesis.
2.  Double click the left mouse button.  The cursor will move to the matching brace or parenthesis.

Alternatively, using the keyboard

1.  Move the caret to a brace or parenthesis.
2.  Press Shift+F1.  The cursor will move to the matching brace or parenthesis.

8. Searching for a Pattern

The Goto Search and Goto Replace commands search for a text pattern.  The pattern can consist of ordinary
characters, the anchor character, escape sequences, wildcard characters, and character classes.  The pattern is
applied to each line of the input text.

The anchor character, ^, matches the beginning of the line.  To be recognized, it must be the first character in the
pattern.

The escape sequences are

\a alert
\b backspace
\f formfeed
\t tab
\v vertical tab
\x the character x

The wildcard characters are

? to match any single character
* to match zero or more characters

A character class is specified as follows

[ list of characters ]

and matches any character in the list of characters.

9. Using the mouse

ARIS EDIT Lite uses the left and right mouse buttons.

For the left mouse button:

A single click moves the input caret to the character nearest the mouse cursor.
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A double click selects the word containing the mouse cursor.  If the cursor is on a parenthesis or brace instead of
on text, double clicking moves the caret to the matching parenthesis or brace.
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Shift + double click also selects the current word. If the cursor is on a file name, ARIS EDIT Lite attempts to
open the file.  It will search the INCLUDE environment string to find the file.

Moving the mouse with the button down (i.e., dragging) selects an arbitrary object.  To select complete lines of
text, keep the mouse at the left edge of a window.

For the right mouse button:

Single click pastes the contents of the clipboard at the mouse cursor.

Dragging selects an arbitrary object.  Upon releasing the button, the object is cut to the clipboard.

Shift + dragging copies the object instead of cutting it.

10. The smart icon bar

The smart icon bar is located just under the menu of ARIS EDIT Lite and allows single click access to several
often used functions.

The picture above shows the icon bar completely. You will note that the spacing divides it into several sections.
Each section belongs to a certain group of commands which will be explained in this chapter.

The first group consists of three buttons, which are all related to file operations. The first button creates a new
empty window and thereby causes the same function as if you select "New" from the file menu. The second
button corresponds to the topic "Open..." from the same menu and the third button saves the current file to disk.
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The next group of three buttons corresponds to the major functions of the edit menu. To cut, copy or paste text
simply press the according button.

The next two buttons are associated to the undo and redo commands of the edit menu. To undo the last editing
operation press the first button in this group, to reverse the last undo operation press the second button.

These two buttons rearrange the currently opened windows. The first button tiles the windows vertical and the
second  horizontal.  However,  with  a  large  number  of  open  windows pressing  each  button  may arrange the
windows in the same sizes and locations.

The first of the last two buttons prints the current file and thereby is equal to the topic "Print..." in the file menu.
The second button activates the help of ARIS EDIT Lite and shows you the table with its keyboard layout.
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11. The keyboard layout of ARIS EDIT Lite

Alt+BkSp Edit Undo
Shift+BkSp Edit Redo
Ctrl+Ins Edit Copy
Ctrl+DelEdit Cut
Shift+Ins Edit Paste
Grey Plus Edit Copy on the current line
Grey Minus Edit Cut on the current line
Insert Edit Paste before the current line

Ctrl+L Goto Line
Ctrl+S Goto Search
Ctrl+R Goto Replace

Ctrl+Y Delete the current line
Ctrl+G File Grep
Ctrl+P Run program
Ctrl+Q Delete to the end of line
Ctrl+W Highlight current word
Ctl+Home Go to the beginning of file
Ctl+End Go to the end of file
Ctl+Right Go to start of next word
Ctl+Left Go to start of previous word

F1 Help on ARIS EDIT Lite
Shift+F1Load file under cursor
F2 Save current file
F5 Search forwards for a character
Shift+F5Search backwards for a character

F3 Run the keyboard macro
Shift+F3Start recording the keyboard macro
F4 Undo change of location in the current file
Shift+F4Redo change of location in the current file

Ctrl+F4 Close current document window
Ctrl+F6 Switch to next document window
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